Dragon Age: Inquisition Modding Tools

All about modding tools for Dragon Age: Inquisition
It is currently Mon Jun 26, 2017 12:08 pm

All times are UTC

Welcome to the Dragon Age Modding tools forum

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Fixing the vertices/coordinates error + morpher modifier?
PostPosted: Sun Apr 30, 2017 6:50 pm 

Joined: Thu Apr 27, 2017 9:52 pm
Posts: 1
Has thanked: 0 time
Have thanks: 0 time
So I've gotten the errors "Imported obj does not contain the same number of texture coordinates as the base mesh in one of its LODs." and "Resource failed to import: Imported obj does not contain the same number of vertices as the base mesh in one of its LODs." quite some times now, and since I feel like I'm finally on the right track to finishing it I figured I'd make a thread about it to keep other clueless beginners like me from wasting hours messing around in the dark with no answers. But since I'm still unsure about/questioning a few things, I won't post this in the tutorial section. This is focused on hair meshes only, but it might apply to others as well. I should mention that I have zero knowledge of programming or 3d modeling, so all this is from a beginners perspective.

I've been working on my first mod for quite a few days now, and ran into both problems above. After having scoured this forum and nexus for a while, I still hadn't found a solution for the troubles I've been having. While I'm still not completely sure I've fixed it, I think I might be onto something. Anyways, I wanted to start this thread to mention things I couldn't find anywhere else on this forum and I think might be worth putting out there in case someone else runs into the same thing. It might be completely obvious to those of you who are well versed with modding, apologies for that. If you have another solution that could fix either of the two errors, please tell me so I can edit it in (and learn from it ;3)

1. Import/export settings might be incorrect
This is the first thing worth checking. For 3ds Max users, it should be the same as Ottemis helpfully showed in this thread:

2. You deleted some vertices
This one speaks for itself. If you want to get rid of a certain strand, downscale it and hide it somewhere inside the head rather than removing it.

3. You created the obj in ModMaker v1.1.0.19
This is the part I couldn't find anywhere else, probably because it's a pretty dumb mistake. As mentioned in another thread, v19 is bad with creating hair mods. At first I assumed this would only mean I shouldn't create the .daimod file itself in v 19, but apparently it doesn't export hair quite as well either. After creating an obj of mh_hm_e_model_mesh in v17 I compared it to the one I started out with in Max, only to realize that some planes in the back were entirely different. The vertices are the same (4121), but the texture coordinates problem might've been caused by that.

That's how far I've gotten atm, so it might turn out to be something else after all.
Right now I'm trying to merge the parts I already finished with the v17 version of the mesh to avoid having to start over completely. This might not actually work however, so I'll update once I know.
The only problem I'm currently struggling with is the texture coordinates one.

Now to the second part of the thread, I've read something about a morpher modifier somewhere, would that be something that'd allow me to put the changes I've made in the v19 mesh into the v17 mesh? And would anyone be so kind to explain how it works? :'3c

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: