Dragon Age: Inquisition Modding Tools

All about modding tools for Dragon Age: Inquisition
It is currently Sun Jun 25, 2017 3:49 pm

All times are UTC



Welcome
Welcome to the Dragon Age Modding tools forum

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic Reply to topic  [ 42 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Author Message
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Wed May 27, 2015 4:41 pm 
Offline

Joined: Wed May 27, 2015 4:21 pm
Posts: 2
Has thanked: 0 time
Have thanks: 3 time
Hello! I just recently started tinkering with hair meshes, but I’m running into a bit of a snag. Once imported into toolset, there are some random black patches on the hair that I can’t seem to fix. I followed your “Fixing dark patches on your hairstyle” instructions, which did help immensely with some weird shading problems on the hair, but a few small, stark black patches are still there and show up in-game. I tested this out on a couple of other meshes with the same result - am I exporting them incorrectly or something? I've been troubleshooting for hours now.

ImageImageImage

They don’t really seem to be visible issues in 3DS Max, so I’m not quite sure how to go about fixing them. If you have any advice, please let me know! And thank you so much for creating this tutorial.

EDIT - Skaramoosh gave me some advice over on the nexus to try out: Select "Element", pull out the problem strand. Then click "Vertex" and select all the vertices. Scale down the vertices to zero. It will just look like a tiny dot once you're done. Hide this little "dot" within the hair mesh. Then just export and preview in the modding tool to check.

I'm going to give that a try on a couple of meshes right now, but for the most part I've been circumnavigating this issue by just hiding the black pieces under other pieces of hair on which the normals are displaying correctly. Still, if anyone has a more "simple" solution, please let me know.


Last edited by dragoncakes on Thu May 28, 2015 2:02 pm, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Thu May 28, 2015 1:05 pm 
Offline

Joined: Tue May 26, 2015 8:15 am
Posts: 6
Has thanked: 6 time
Have thanks: 0 time
Hi there!

First of all I want to thank you for this tutorial, for all your hard work and your patience.

I'm totally new in editing hair but I love this game so much and I wanted to give it a try.
First when I exported some hair meshes then imported them into 3ds Max, they came out totally black.
I tried with the files that a very kind soul put on his google drive (I don't remenber the name but immense thank you by the way) and the meshes were displayed correctly. There's certainly something I did wrong.
Indeed, I found out that I needed to edit the files a little by replacing in a text editor the "," by ".". That was all.

Edit: I finished my first attempt of editing a hair mesh. Finally, I used the "hm_g.obj" file downloaded on google drive. Unfortunately, when I tried to import it back in the file of the DAI modding tool "mh_hm_g_model_mesh.obj", after selecting the scale 1, the tool crashed immediately. I followed the instructions in step 6 but maybe I should have unchecked other options or probably that the numbers of vertex and objets are different. I don't know how but I have to check that. It's true that the new .obj file doesn't have the same size as the original one.

Edit2: I just tried to import back the original "hm_g.obj" which normally should be exactly the same as the "mh_hm_g_model_mesh.obj" one. I even tried to replace the "." by the "," (since the files exported contained ","). When the window pop-up, I kept the global scale at 1 and clicked save. And the tool crashed.

Do you have any kind of idea? I really don't know what to do.

Would it be possible that one of you could make a video to explain the commands to use in 3ds Max during the process of editing the hair meshes, and importing back hair meshes in DAI modding tool, please?


Anyway you're amazing. Good continuation!


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Sat May 30, 2015 9:07 pm 
Offline

Joined: Wed May 27, 2015 4:21 pm
Posts: 2
Has thanked: 0 time
Have thanks: 3 time
Lauremarti wrote:
Hi there!

First of all I want to thank you for this tutorial, for all your hard work and your patience.

I'm totally new in editing hair but I love this game so much and I wanted to give it a try.
First when I exported some hair meshes then imported them into 3ds Max, they came out totally black.
I tried with the files that a very kind soul put on his google drive (I don't remenber the name but immense thank you by the way) and the meshes were displayed correctly. There's certainly something I did wrong.
Indeed, I found out that I needed to edit the files a little by replacing in a text editor the "," by ".". That was all.

Edit: I finished my first attempt of editing a hair mesh. Finally, I used the "hm_g.obj" file downloaded on google drive. Unfortunately, when I tried to import it back in the file of the DAI modding tool "mh_hm_g_model_mesh.obj", after selecting the scale 1, the tool crashed immediately. I followed the instructions in step 6 but maybe I should have unchecked other options or probably that the numbers of vertex and objets are different. I don't know how but I have to check that. It's true that the new .obj file doesn't have the same size as the original one.

Edit2: I just tried to import back the original "hm_g.obj" which normally should be exactly the same as the "mh_hm_g_model_mesh.obj" one. I even tried to replace the "." by the "," (since the files exported contained ","). When the window pop-up, I kept the global scale at 1 and clicked save. And the tool crashed.

Do you have any kind of idea? I really don't know what to do.

Would it be possible that one of you could make a video to explain the commands to use in 3ds Max during the process of editing the hair meshes, and importing back hair meshes in DAI modding tool, please?


Anyway you're amazing. Good continuation!


As you can see from my previous comment, I'm no expert, but I can try to put together a video for you explaining the process that works for me? I'll edit this post when it's finished.

EDIT: I make a very basic video explaining the process over at the nexus (http://www.nexusmods.com/dragonageinquisition/images/3985/?), or if you just want to go straight to the video it's on youtube (https://youtu.be/XGxcC_Omcpc). I apologize for my lack of experience and for any inaccuracies - this is just the process that works for me.
dragoncakes has been thanked by:


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Sun May 31, 2015 8:24 pm 
Offline

Joined: Tue May 26, 2015 8:15 am
Posts: 6
Has thanked: 6 time
Have thanks: 0 time
You are wonderful! Thank you so much dragoncakes, it really is helpful! Your video summed up everything I wanted to know and I think it's a good support for this topic.
I've seen that you're using v.1.27. I tried to use it too (and also 1.26) but I couldn't manage to make them work. Even after putting the "daimodding.ini" in each folder, when I clicked on the .exe file, nothing happened. So I'm using v.1.31 which opens just fine and loads all the datas, meshes...
Anyway, thank to your video, I will try again and see, using the same options as you, if I can import a mesh back in the tool. I will edit this post later if I'm successful or not ;)
Thank again for having taken the time to create and post the video. I'm really grateful.

Edit: Ok so the test was quick and unsuccessful. I still need to edit the exported .obj file by replacing the "," by "." if not, the hair don't show up in 3DS MAX. The modding tool continues to crash when I try to import back the new .obj file. So now I think I will go to the "Testing ModdingTool v1.31 for patch7" topic ;)


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Sun May 31, 2015 11:43 pm 
Offline

Joined: Wed Apr 29, 2015 3:43 am
Posts: 55
Has thanked: 50 time
Have thanks: 104 time
dragoncakes wrote:
Hello! I just recently started tinkering with hair meshes, but I’m running into a bit of a snag. Once imported into toolset, there are some random black patches on the hair that I can’t seem to fix. I followed your “Fixing dark patches on your hairstyle” instructions, which did help immensely with some weird shading problems on the hair, but a few small, stark black patches are still there and show up in-game. I tested this out on a couple of other meshes with the same result - am I exporting them incorrectly or something? I've been troubleshooting for hours now.

Spoiler:
ImageImageImage


They don’t really seem to be visible issues in 3DS Max, so I’m not quite sure how to go about fixing them. If you have any advice, please let me know! And thank you so much for creating this tutorial.

EDIT - Skaramoosh gave me some advice over on the nexus to try out: Select "Element", pull out the problem strand. Then click "Vertex" and select all the vertices. Scale down the vertices to zero. It will just look like a tiny dot once you're done. Hide this little "dot" within the hair mesh. Then just export and preview in the modding tool to check.

I'm going to give that a try on a couple of meshes right now, but for the most part I've been circumnavigating this issue by just hiding the black pieces under other pieces of hair on which the normals are displaying correctly. Still, if anyone has a more "simple" solution, please let me know.


Sorry I didn't get back to you about this sooner -- I totally forgot to check up on this thread. However, Skaramoosh's advice is about the best you're going to get at the moment. I've encountered this problem too, and haven't been able to figure out what causes it; I addressed it by hiding the problem geometry. (I just tuck things behind non-problem parts of the mesh, rather than scaling, but the net result is the same.) If I come up with a solution I'll post about it in this thread, but for now I got nothin'. (That mod looks great, though!)

Edit: The dark patches only seem to appear on meshes that've had the import-export autonormals ritual performed on them, so for slight mesh changes that aren't causing normals artefacts, you can just skip that step. You have to export the original mesh anyway, so you might as well test it in the tool. Sounds like that isn't relevant in this case, but it's something to keep in mind.

Lauremarti, the problems you're having are largely beyond me. (The , vs . thing sounds like it may be a localization issue?) However, Modding Tool 1.27 not starting is familiar. I believe I had this issue, and the problem was that I needed to roll my game back to patch 5, scan with 1.26, then restore patch 6 and copy the ini (and perhaps the cache?) from the 1.26 directory into the 1.27 directory. You can get a copy of patch 5 here.


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Mon Jun 01, 2015 7:35 am 
Offline

Joined: Tue May 26, 2015 8:15 am
Posts: 6
Has thanked: 6 time
Have thanks: 0 time
Hi Squid! Thanks for the reply :)

I already tried rolling back to patch 5 (using exactly the one in the topic you mentionned) to try using the 1.26 modding tool. I grabbed the 'daimodding.ini' in the 1.31 version and edited it like this:
BasePath=C:\Program Files (x86)\Origin Games\Dragon Age Inquisition\
CacheVersion=5
PatchVersion=6
Language=en
Author=BobbyBob
GlobalMeshScale=1
Version=v1.26 alpha

I moved the "black emporium" folder and all the deluxe content elsewhere.
Nothing happened and running it as administrator has no effect either.


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Mon Jun 01, 2015 6:07 pm 
Offline

Joined: Wed Apr 29, 2015 3:43 am
Posts: 55
Has thanked: 50 time
Have thanks: 104 time
Have you tried running 1.26 with patch 5 and no .ini or cache files at all?


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Mon Jun 01, 2015 8:14 pm 
Offline

Joined: Tue May 26, 2015 8:15 am
Posts: 6
Has thanked: 6 time
Have thanks: 0 time
I just tried what you suggested with patch 5. I don't have any cache files since it never has scan anything. I also deleted the .ini but still nothing. Thanks for trying to help me.


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Tue Jun 02, 2015 3:21 am 
Offline

Joined: Wed Apr 29, 2015 3:43 am
Posts: 55
Has thanked: 50 time
Have thanks: 104 time
You're welcome. I'm just sorry I can't be of more help; I've run out of things for you to try. I'm just an end user, though, so you might have better luck with people on the programming side.
Squid has been thanked by:


Top
 Profile  
 
 Post subject: Re: Hair Tutorial by Adela and Squid
PostPosted: Tue Jun 02, 2015 7:09 pm 
Offline

Joined: Wed Feb 11, 2015 5:04 pm
Posts: 5
Has thanked: 4 time
Have thanks: 16 time
This probably isn't a very helpful post since I have yet to find a solution, but I've been having the same problem as Yasmeleon with the specific Female Qunari bun mesh--qf_114_h to be precise. I've built other fully functional hair mods following the tutorial (and thanks so much for it!), but the changes I've made to this particular hairstyle do not show up at all in game after saving and merging the mod. I had another person test the import of my edited .obj to no avail. For now I'm just chalking it up to a specific bug with this model, though someone wiser might have a better idea of what's going on.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 42 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred