Dragon Age: Inquisition Modding Tools

All about modding tools for Dragon Age: Inquisition
It is currently Fri Jun 23, 2017 11:57 pm

All times are UTC



Welcome
Welcome to the Dragon Age Modding tools forum

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!


Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 139 posts ]  Go to page 1, 2, 3, 4, 5 ... 14  Next
Author Message
 Post subject: Patch8 Mod Manager version 57 by Zhentar
PostPosted: Fri Jul 10, 2015 11:34 am 
Offline
Site Admin

Joined: Fri Dec 05, 2014 4:27 am
Posts: 156
Has thanked: 242 time
Have thanks: 414 time
Version 57 is out! :D

First of all a big THANK YOU to Zhentar for fixing the bugs so quickly! :D
Also, as stated below, some mods are simply broken due to patch 9 and there's nothing we can do about it.
The authors will have to update their mod in order for them to work.
Thank you all for your patience!

Direct Links
(32 bits) : https://www.dropbox.com/s/2rf568pw901sf ... 7.zip?dl=0
(64 bits) : https://www.dropbox.com/s/v9491el8rv3w9 ... 7.zip?dl=0


Recent Updates:
* [FIXED] Configurable mods load in a loop indefinitly.
* Improved performance

Known issues:
* Some mods are simply broken due to Patch 9. The author will have to recreate it.

Past Updates:
* Fixes the NullReferenceException
* Tiny fix for default path when setting the mod path.
* Patch 8 Compatible! No longer crashes when processing Patch 8.
* Renamed Project branch to Mod Manager v1.0
* Added version check of the ModMaker to filter out incorrect .daimod files.
* Added taskbar progress status


Report this post
Top
 Profile  
 
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 1:53 pm 
Offline
User avatar

Joined: Thu May 14, 2015 5:29 pm
Posts: 11
Has thanked: 11 time
Have thanks: 0 time
Thanks for all you do (for all devs)...
We (I think I can talk about it for every players) love use mods!!!

_________________
Dragon Age Maniac


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 2:13 pm 
Offline
User avatar

Joined: Thu May 14, 2015 5:29 pm
Posts: 11
Has thanked: 11 time
Have thanks: 0 time
Adela wrote:
First of all a big THANK YOU to Zhentar and all his hard work. He released a new version of Mod Manager last night via DAIToolsSuite. However I see that some people are having issues with updating the tool through the Suite. If that doesn't work for you try this direct link here : http://www.mediafire.com/download/z8cr9 ... ger+53.zip
Also this *should* be fixing the other errors that people were getting when merging. Hope this works for you guys. I personally did not had to move any files from the update such as BE or the JoH. Altho I did have to delete the old merge folder that i had of mods and create a new one using V53

Enjoy


I have this problem here

=>
[10/07/2015 11:05] [0] Processing C:\Program Files (x86)\Origin Games\Dragon Age Inquisition\Update\Patch\Data\Win32\da3_dlc_blackemporium\da3_dlc_blackemporium.toc
[10/07/2015 11:05] [1] Processing bundle win32/da3_dlc_blackemporium/da3_dlc_blackemporium
[10/07/2015 11:05] Task failed. Error reported was: Object reference not set to an instance of an object.
<=

_________________
Dragon Age Maniac


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 2:23 pm 
Offline

Joined: Thu Mar 26, 2015 7:12 pm
Posts: 8
Has thanked: 0 time
Have thanks: 92 time
That issue should be fixed by the new version. You could try a 'Repair Game' to see if that affects it, but if you want to upload a copy of your da3_dlc_blackemporium.toc and da3_dlc_blackemporium.sb files somewhere I'd be interested to see why it's failing.

Edit: never mind, the loader isn't pulling in the right version for some reason; I'll have to check it out.

Edit 2: fixed, try hitting 'Upgrade' in the loader


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 2:32 pm 
Offline

Joined: Sun Feb 08, 2015 7:58 am
Posts: 307
Has thanked: 263 time
Have thanks: 321 time
Thank you, Zhentar!

Edit:

I tried the new version, and I think it is something to do with the BE files themselves. Here's what I found:

When I tried to run the MM 53, it would throw the dlc_blackemporium error. When I deleted the Patch folder and BE folder, Repaired the game, and then redownloaded the BE (like theskymoves stated in another thread), it worked fine.

On a lark, I copied my old copy of the BE files back in, and got the same error. Re-downloaded the BE, and got the same error.

It's only when I delete the BE and Patch, then do a Repair game and re-download the BE, that the MM 53 works without error. It's weird, but it's reproducible.
tklivory has been thanked by:


Last edited by tklivory on Fri Jul 10, 2015 2:41 pm, edited 3 times in total.

Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 2:37 pm 
Offline

Joined: Fri Jun 05, 2015 6:24 pm
Posts: 1
Has thanked: 0 time
Have thanks: 0 time
when i opened it the new mod manager it was still v0.52


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 2:40 pm 
Offline

Joined: Sun Feb 08, 2015 7:58 am
Posts: 307
Has thanked: 263 time
Have thanks: 321 time
valkyriexo wrote:
when i opened it the new mod manager it was still v0.52


That's just the GUI, it *is* v0.53, I've been able to use it to merge successfully several times now.


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 3:18 pm 
Offline

Joined: Sat Apr 18, 2015 6:06 pm
Posts: 54
Has thanked: 45 time
Have thanks: 24 time
doesn't work... not only does it choke on the Black Emporium even when I remove that and do an empty modless merge it throws out a can't be done due to another instance already existing... the progress bar stops at the loctext RU.TOC file...


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 3:20 pm 
Offline
User avatar

Joined: Mon Feb 23, 2015 1:24 am
Posts: 61
Location: Ontario, Canada
Has thanked: 49 time
Have thanks: 92 time
tklivory wrote:
Thank you, Zhentar!

Edit:

I tried the new version, and I think it is something to do with the BE files themselves. Here's what I found:

When I tried to run the MM 53, it would throw the dlc_blackemporium error. When I deleted the Patch folder and BE folder, Repaired the game, and then redownloaded the BE (like theskymoves stated in another thread), it worked fine.

On a lark, I copied my old copy of the BE files back in, and got the same error. Re-downloaded the BE, and got the same error.

It's only when I delete the BE and Patch, then do a Repair game and re-download the BE, that the MM 53 works without error. It's weird, but it's reproducible.

Thank-you so much! I was having the same problem and the above steps worked :)

_________________
Tumblr http://guidethisonekalahira.tumblr.com/ Flickr https:[email protected]/ Nexus http://www.nexusmods.com/dragonageinquisition/users/6747948/? Steam http://steamcommunity.com/id/guidethisonekalaheria
kalaheria has been thanked by:


Report this post
Top
 Profile  
 
 Post subject: Re: Patch8 Mod Manager version 53 by Zhentar
PostPosted: Fri Jul 10, 2015 3:25 pm 
Offline

Joined: Sun Feb 08, 2015 7:58 am
Posts: 307
Has thanked: 263 time
Have thanks: 321 time
Update:

The DAI Tools Suite is downloading a version of MM v0.53 which doesn't have a patch.daimod file. The version which Adela linked in the first post of this thread *does* have a patch.daimod.

When I try to patch using the DAI Tools Suite version, I get the aforementioned dlc_blackemporium error. When I patch using the downloaded version, I don't get an error.

The workaround for it to work without that patch.daimod file in the folder initially is the same one I posted earlier, which allows the MM to make a new patch.daimod file, and after that, the patching works without needing to use the workaround.

So it appears that the main factor between working/not working is the missing patch.daimod file in the DAI Tools Suite version.


Report this post
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 139 posts ]  Go to page 1, 2, 3, 4, 5 ... 14  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred